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A Note From Lynda Weinman

In my opinion, most people buy computer
books in order to learn, yet it is amazing
how few of these books are actually
written by teachers. My co-author,
Garo Green, and | take pride in the
fact that this book was written by
experienced teachers who are
familiar with training students in
this subject matter. In this book,
you will find carefully developed
lessons and exercises to help you

Introduction

| A Note from Lynda | About the Authors | Our Team |
| Acknowledgements | How to Use this Book |
| HTML Versus HTM | Interface Screen Captures |
| System Differences | A Note to Windows Users |

| Making Exercise Files Editable on Windows Systems | learn Dreaimweaver 3 — one.of the

most well-respected HTML editors
on the planet.

| Dreamweaver System Requirements | H*O*T CD-ROM Contents |

H*O°T

This book is targeted towards begin-
ning to intermediate level Web devel-
opers who are looking for a great tool to
speed up production, offer workflow flexi-
bility, and create great code and results. The
premise of the hands-on exercise approach is
to get you up to speed quickly in Dreamweaver 3,
while actively working through the book’s lessons. It's
one thing to read about a product, and an entirely other
experience to try the product and get measurable results.

Dreamweaver 3
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Many exercise-based books take a paint-by-numbers approach to teach-
ing. While this approach works, it's often difficult to figure out how to
apply those lessons to a real-world situation, or understand why or when
you would use the technique again. What sets this book apart is that the
lessons contain lots of background information and insights into each
given subject, which are designed to help you understand the process
as well as the exercise.

At times, pictures are worth a lot more than words. When necessary, we
have also included short QuickTime movies to show any process that's
difficult to explain with words. These files are located on the H*O*T CD-
ROM inside a folder called movies. It's my style to approach teaching
from many different angles since | know that some people are visual learn-
ers, others like to read, and still others like to get out there and try things.
This book combines a lot of teaching approaches so you can learn
Dreamweaver 3 as thoroughly as you want to.

This book didn't set out to cover every single aspect of Dreamweaver.
The manual, and many other reference books are great for that! What
we saw missing from the bookshelves was a process-oriented book that
taught readers core principles, techniques, and tips in a hands-on train-
ing format.

We welcome your comments at dwshot@lynda.com. Please visit our Web
site as well, at http://www.lynda.com. The support URL for this book is
http://www.lynda.com/books/dw3hot/.

It's Garo's and my hope that this book will raise your skills in Web design,
HTML, JavaScript, and publishing. If it does, then we will have accom-
plished the job we set out to do!

-Lynda Weinman

Note | About lynda comlbooks and iynda.rcom
lynda.com/books is dedlcated to helping Web designers and developers understand tools and deslgn

pnnmples lynda.com offers ds-on workshops, training seminars, on-site training, training videos, train-
ing  CDs, and “expert tlps for Web design and development To learn more about our trammg programs,

boaks, and ' roduc:t , be sure io give our site a visit at http://www. lynda com
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About the Authors

Lynda Weinman

Lynda has been practicing computer design and animation since 1984, when she bought
one of the first Macintosh computers. She worked as an animator and motion graphics direc-
tor in the special effects industry for seven years before having a daughter in 1989. At that
time, she was asked to teach her first workshop in multimedia animation, and eventually
became a full-time faculty member at Art Center College of Design in Pasadena, California.

Lynda has been a beta tester for imaging and animation software packages since 1984,

and has worked as a consultant for Adobe, Macromedia, and Microsoft. She has conducted
workshops at Disney, Microsoft, Adobe, and Macromedia, and has been a highly sought-after
keynote speaker, moderator and/or speaker at numerous design, broadcast design, anima-
tion, Web design, and computer graphics conferences.

Lynda is the co-founder of lynda.com, which specializes in Web design training via hands-on
classes, seminars, training videos, books, Web tips, and CD-ROMs. Visit her site,
http://www.lynda.com to learn more....

Garo Green

Garo Green is the Director of Training at lynda.com in Ojai, California. His respon-
sibilities include course and curriculum development, faculty selection/training, as
well as managing on-site training. Prior to joining lynda.com, Garo was a software
instructor and Intranet developer for State Farm Insurance Company.

Garo has worked extensively in the development of custom curriculum and course-
ware for software training. He has over five years of teaching experience in both
hardware and software applications. In addition, he has an extensive knowledge of
HTML, computer graphics, and Web design. He is well versed in Dreamweaver,
Fireworks, Flash, Freehand, Photoshop, GoLive, and ImageReady.

Garo is the co-author of the Dreamweaver 3 H*O+T book and Learning Dream-
weaver 3 CD-ROM. He has also been a featured speaker at the Web99 and Flash-
Forward2000 conferences.

In his spare time... (well, he doesn't have much of that anymore, but that's OK) he
has found that his passion for teaching and sharing what he knows is very fulfilling.
He does sneak away, several times a day, to the local coffeehouse for a double-latte
with hazelnut. Of course this might explain why he talks so fast. ;-)

| xii |
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Our Team

The lynda.com training center offers classes
in Dreamweaver, Flash, Fireworks, Photo-
shop, ImageReady, GolLive, and Web design
principles. Visit www lynda.com/classes for
more information.

Lynda and Garo take a break from their
busy schedules to smile at the camera.

A blurry Bruce and Lynda at their
training center via digital camera.

Lynda’s daughter Jaimie

in a very serious mood Lynda with book designer, Ali Karp
(as usual). at their combination book signing
- - and photography exhibit.
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Acknowledgements from Lynda

| could not have written this book without the help of several key people.
Special thanks to:

My writing partner on this project, Garo Green, who is not only someone I'm proud to call a dear friend, but
who has an amazing gift for educating and sharing his vast knowledge with others.

My book designer, the always incredible Ali Karp, who not only laid out pages, but also beta tested, took a
Dreamweaver workshop from us, and gave her usual 200% to this project. This is the 12th book that Ali and
| have collaborated on in five years. Wow.

My husband, Bruce Heavin, who made the cover art, put up with the countless hours it took to complete this
project, and was always there for moral support (and the ever-important foot massages!).

My daughter, Jamie, who provided ever-important cuddle time with her mom after a hard day’s work on the
book. Thanks for being so understanding and always sharing your sense of humor with me.

My editor at Peachpit, Cary Norsworthy, who contributed numerous great ideas, and whose opinion | always
valued and appreciated. It's a rare treat to get to work with such a fine mind and kind soul. Thanks, Cary.

Our developmental editor, the brilliant Lisa Brenneis, who is not only smart, but has good taste in music
and hometowns. She's da bomb.

Our production artists, Heidi Goodspeed, Sean Blumenthal, and David Reeser. Thanks for making the job
of assembling all the images for this book more manageable for everyone. And | must also thank Pamela Nye
and Sean Dowey for all the “photocopying,’ and “overnight shipping” It was a lot of work!

Our beloved copy editor, Joan Morley, who worked endless hours on this very complicated manuscript.

The folks at Macromedia who made this amazing HTML editor — especially the honorable Kevin Lynch,
whose brilliance and vision is undisputed by all.

All of our fantastic lynda.com staff. You all make having a business much more fun than working out of
my garage. ;-)
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Acknowledgements from Garo

This book, and every other book you read, could not have been possible without a strong team of
dedicated, enthusiastic, and talented individuals. | was fortunate enough to work with the best.
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My co-author and dear friend, Lynda Weinman. Thank you for putting me on your shoulders, so |
could catch my dreams. Your friendship and support made writing this book a pleasure.

My developmental editor (and occasional therapist), Lisa Brenneis. If behind every great man there
is a great woman, then behind every great author there is a great developmental editor. You always
managed to make me smile and keep me inspired, even when the box of Cocoa Pebbles started talk-
ing to me. | hope we will be friends for a long time.

My editor at Peachpit, Cary Norsworthy, who could find a needle in a haystack any day! Your com-
ments and suggestions were always great. Thank you so much for all of your hard work and extra
effort on this book.

My book designer, Ali Karp, who would spend many sleepless nights laying out the pages, chapter
after chapter. Thank you for making my words look so good. You friendship and support carried me
through the good and hard times of writing this book.

My editor, Joan Morley. Boy, it's a good thing you were there to keep me from crossing my I's and
dotting my T's. You did such a great job, even under the tightest deadlines.

My beta testers, Dina Pielaet, Garrick Chow, Ellen Norgard, Cheri Hackett, and Kymberlee Weil. |
want to thank you guys for working so hard and quickly. Your valuable and humorous comments made
it so much fun to write this book, even when it meant rewriting an entire exercise!

My layout assistants, Heidi Goodspeed, Sean Blumenthal, and David Reeser who helped make
sure that all of my images were in order and looked good. | don't know how you guys did it, but thank
you so much!

My friends at Macromedia, Beth Davis, Eric Ott, Mike Sundymeyer, and all of the Dreamweaver
Engineers. Thanks for making such an amazing product! | have really enjoyed working with you guys.

The entire lynda.com staff. Pamela Nye, Tony Winecoff, Heather Rowe, and Ramey McCullough.
You guys make coming to work each day fun; what more could a person ask for?
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How To Use This Book

Please read this section—it contains important information that's
going to help you as you use this book. The chart below
outlines the information we cover:

Information in this Chapter:
The Formatting in This Book
HTML versus HTM

Macintosh and Windows Interface Screen Captures

Mac and Windows System Differences
* Choose versus Select
* Choose on MacOS 8 versus Open on MacOS 9

A Note to Windows Users

* Making Exercise Files Editable on Windows Systems
* Making File Extensions Visible on Windows Systems
* Creating New Documents

Dreamweaver System Requirements

HeOT CD-ROM Contents

Note | The Pomattmg in 'l'lus Book

This book has several components, mc!udmg step-by-step exercises, commentary. notes, ttps, wammgs,
and movies. Step-by-step exercises are numbered, and file names and command keys are bolded so they
pop out more easily. You msght notice that certain words are capltahzed such as Tables Frames Layers,

| xvi |
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HTML Versus HTM

All of the HTML exercise files on the CD-ROM end with an .html extension. Windows users
might be more used to naming files with an .htm extension. You can name your files either
way, and a Web browser will be able to read them. The choice to name them with the four-
letter extension represents a personal bias that we prefer. The shorter .htm suffix is a throw-
back to the old days of DOS when file names were limited to the eight-dot-three convention.
That meant that file names could be no longer than eight characters, and had to end with a
dot and a three-letter extension. Those days are history since the advent of Windows 95/98/
2000, so we named all the files with the more accurate four-letter extension. It does, after all,
stand for HyperText Markup Language, not HyperText Markup! Now you know why we chose
to name the files this way, but the bottom line of this explanation is that you can use either
naming method and your HTML files will still work as long as they have been referenced this
way in the links. We simply made a choice to use the four-letter extension because that's
what we prefer to use.

Macintosh and Windows Interface Screen Captures

Most of the screen captures in the book were taken on a Macintosh. The only time Windows shots
were taken was when the interface differed from the Macintosh. We made this decision because we
do most of our design work and writing on a Macintosh. We also own and use a Windows system,
so we noted important differences when they occurred, and took screen captures accordingly.

Mac and Windows System Differences

Macromedia has done a great job of ensuring that Dreamweaver looks and works the same between
the Macintosh and Windows operating systems. However, there are still some differences that should
be noted. If you are using this book with one of the Windows operating systems, please be sure to
read the following section, titled “A Note to Windows Users,” carefully.

| xvii |
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A Note to Windows Users

This section contains essential information about making your exercise folders editable, making file
extensions visible, and creating new Dreamweaver documents from the document window versus the
Site window.

Making Exercise Files Editable on Windows Systems

By default, when you copy files from a CD-ROM to your Windows 95/98/2000 hard drive, they are
set to read-only (write protected). This will cause a problem with the exercise files, because you will
need to write over some of them. When you define a site (you will learn to do this in Chapter 3, “Site
Control”), you will notice that the files have a small lock next to them which means the files have been
set to read-only. To remove this setting and make them editable, follow the short procedure below:

. Site - Chapter 3

@ reservations. gif
reserve. html

reserve_bg gif

B @ reservetitie. gif
[ @ room1.jpg
8 @ room2 jpg
room3.jpg
- [ @ roomd.jpg
[ @ roomS.jpg
[ & room6.jpg

.

m7.ipg o

gaoal o a“*.'nﬁ.}‘%:dﬂ
et e e :

1. Define your site using the folder you copied from the H*OsT CD-ROM. When the Site
window opens, you will see little locks next to all of the files.
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< Site - Chapter 3

Eifecigaizatl
1

Bl

3. Once you have all of the files selected, select File > Turn Off Read Only.
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Making File Extensions Visible on Windows Systems

In this section, you'll see three different examples of how to turn on file extensions for Windows 95,
Windows 98, and Windows 2000. By default, Windows 95/98/2000 users will not be able to see file
extension names such as .gif, .jpg, or .html. Don’t worry, you can change this setting!

Windows 95 Users:

1. Double-click on the My Computer icon on your desktop. Note: If you (or someone else)
have changed the name, it will not say My Computer.

2. Select View > Options. This will open the Options dialog box.

3. Click on the View tab at the top. This will open the View options screen so you can
change the view settings of Windows 95.

4. Make sure there is no checkmark in the Hide MS-DOS file extensions for file types that
are registered box. This will ensure that the file extensions are visible, which will help you
better understand the exercises in this book!
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Windows 98 Users:

1. Double-click on the My Computer icon on your desktop. Note: If you (or someone else) have
changed the name, it will not say My Computer.

[ Allow all uppercase names

[ Display the full path in title bar

Hidden files
QO Do not show hidden files
® Do not show hidden or system files
Q Show all files

Remember each folder's view settings
[ Show file attributes in Detail View
[ Show Map Netwark Drive button in toolbar B
2] Show pop-up description for folder and desktop tems. 8],

“b
»
.
i
A
|

3. Click on the View tab at the top. This will open the View options screen so you can change the
view settings of Windows 98.

4. Uncheck the Hide File extensions for known file types checkbox. This will make all of the file
extensions visible.

| xxii |



