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PREFACE

PURPOSE

My decision to write a Pro/ENGINEER textbook was based on the lack of a comprehen-
sive textbook on this popular computer-aided design package. I focused on several objec-
tives and ideas when I started to develop this project:

To write a textbook for an introductory course in engineering graphics.

2. To meet the needs of institutions teaching a course on parametric design and
constraint-based modeling.

3. To create a book that would serve as a self-paced, independent study guide for the
learning of Pro/ENGINEER for those who do not have the opportunity to take a
formal course.

4. To incorporate a tutorial approach to the learning of Pro/ENGINEER in conjunction
with detailed reference material.

5. To include topics that make the text a suitable supplement for an upper division
course in mechanical design.

APPROACHES TO USING THE TEXTBOOK

This textbook is designed to serve as a tutorial, reference, and lecture guide. Chapters start
by covering selected topics in moderate detail. Following the reference portion of each
chapter are one or more tutorials covering the chapter’s objectives and topics. At the end of
each chapter are practice problems used to reinforce concepts covered in the chapter and
previously in the book.

I had several ideas in mind when developing this approach to the book. Since
Pro/ENGINEER is a menu-intensive, computer-aided design application, the most practi-
cal pedagogical method to cover Pro/ENGINEER’s capabilities (that would be the most
beneficial both to students and instructors) would be to approach this book as a tutorial. In
addition to the provided tutorials, this book provides detailed reference material. A typical
approach to teaching Pro/ENGINEER would be to provide a tutorial exercise followed
by a nontutorial practice or practical problem. Usually students can complete the tuto-
rial, but they may run into problems on the practice exercise. One of the problems that
Pro/ENGINEER students have is digging back through the tutorial to find the steps for per-
forming specific modeling tasks. The reference portion of each chapter in this text provides
step-by-step guides for performing specific Pro/ENGINEER modeling tasks outside of a
tutorial environment.

STUDENTS OF PRO/ENGINEER

One of the objectives of this book is to serve as a stand-alone text for independent learners
of Pro/ENGINEER. This book is approached as a tutorial to help meet this objective. Since
Pro/ENGINEER is menu intensive, tutorials in this book use numbered steps to guide the
selection of menu options. The following is an example of a tutorial step:

Step 6:

Place Dimensions according to Design Intent.

Use the Dimension icon to match the dimensioning scheme shown in

Figure 4-24. Placement of dimensions on a part should match design intent.
With Intent Manager activated (Sketch >> Intent Manager), dimensions and
constraints are provided automatically that fully define the section.
Pro/ENGINEER does not know what dimensioning scheme will match design
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intent, though. Due to this, it is usually necessary to change some dimension
placements.

MODELING POINT f possible, a good rule of thumb to follow is to avoid modifying the section’s
dimension values until your dimension placement scheme matches design infent.

The primary menu selection is shown in bold. In this example, you are instructed to use the
dimension option (portrayed by the Dimension icon) to create dimensions that match the
part’s design intent. Following the specific menu selection, when appropriate, is the ratio-
nale for the menu selection. In addition, Modeling Points are used throughout the book to
highlight specific modeling strategies.

CHAPTERS
The following is a description and rationale for each chapter in the book:

CHAPTER 1 PRO/ENGINEER’S USER INTERFACE

This chapter covers basic principles behind Pro/ENGINEER’s interface and menu
structure. The purpose is to serve as a guide and reference for later modeling
activities. A tutorial is provided to reinforce the chapter’s objectives.

CHAPTER 2 EXTRUDING, MODIFYING, AND REDEFINING FEATURES

Chapter 2 is the first chapter covering Pro/ENGINEER s solid modeling capabilities.
Pro/ENGINEER’s protrusion and cut commands are introduced and the extrude
option is covered in detail. In addition, modification and datum plane options are
introduced.

CHAPTER 3 FEATURE CONSTRUCTION TOOLS

While the protrusion and cut commands are Pro/ENGINEER s basic tools for
creating features, this chapter covers additional feature creation tools. Covered in
detail are the hole, round, rib, and chamfer commands; creating draft surfaces;
shelling a part; cosmetic features; and creating linear patterns.

CHAPTER 4 REVOLVED FEATURES

Many Pro/ENGINEER features are created by revolving around a center axis.
Examples include the revolve option found under the protrusion and cut commands
and the sketched hole option. These options, along with creating rotational patterns
and datum axes, are covered in this chapter.

CHAPTER 5 FEATURE MANIPULATION TOOLS

Pro/ENGINEER provides tools for manipulating existing features. Manipulation
tools covered include the group option, copying features, and creating relations.

CHAPTER 6 CREATING A PRO/ENGINEER DRAWING

Since Pro/ENGINEER is primarily a modeling and design application, the creation
of engineering drawings is considered a downstream task. Despite this, there is a
need to cover the capabilities of Pro/ENGINEER’s drawing mode. This chapter
covers the creation of general and projection views.

CHAPTER 7 SECTIONS AND ADVANCED DRAWING VIEWS

Due to the length and depth of Chapter 8, the creation of section and auxiliary views
is covered in a separate chapter.

vii
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CHAPTER

PRO/ENGINEER’S USER INTERFACE

Pro/ENGINEER has both a UNIX and Windows version (NT, 95, and 98). Starting with
Release 20, Pro/ENGINEER introduced a new interface. This interface resembles, on its
face, a typical Windows application. When manipulating Pro/ENGINEER, it is important
to remember that it does not function like a true Windows application. This chapter will in-
troduce the fundamentals of Pro/ENGINEER’s interface. Upon finishing this chapter, you
will be able to

 Describe the purpose behind each menu on Pro/ENGINEER’s menu bar.

» Use Pro/ENGINEER’s file management capabilities to save object files.

¢ Set up a Pro/ENGINEER object to include units, tolerances, and materials.

e Customize Pro/ENGINEER through the use of the configuration file.

e Customize Pro/ENGINEER commands using mapkeys.

¢ Organize items using the Layers option.

DEFINITIONS

Configuration file A Pro/ENGINEER file used to customize environmental and global settings.
Configuration options can be set through the Utilities >> Preferences option.

Mapkeys Keyboard macros used to define frequently used command sequences.
Model An object that represents the actual sculptured part, assembly, or work piece.
Nominal dimension A dimension with no tolerance.

Object A file representing an item, part, assembly, drawing, layout, or diagram created in
Pro/ENGINEER.

Tolerance The allowable amount that a feature’s size or location may vary.

MENU BAR

The following describes many of the options available on Pro/ENGINEER’s Part mode
menu bar (see Figure 1-1). While this interface may appear to make Pro/ENGINEER a
true Windows application, many typical Windows functions are not available (Copy,
Paste, etc.).
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Figure 1-1 Pro/ENGINEER's work screen

F1LE MENU

The File menu is Pro/ENGINEER’s interface for the manipulation of files and
objects. Found under the File menu are options for saving and opening objects. Also,
options are available for printing and exporting objects.

EpiT MENU

The Edit menu provides options for the modification of geometric elements. Within
part mode, options are available for performing feature manipulation and
modification techniques such as Redefine, Reroute, Suppress, and Delete. Within
sketch mode, options are available for moving, copying, and trimming sketched
entities.

VIEwW MENU

The View menu is used to change the appearance of models and Pro/ENGINEER’s
work screen. Many of the view options available exist as shortcut keys or can

be found on the Toolbar. Commonly used view manipulation options under the
View menu include zooming, repainting the view, and retrieving the default view.
Options also are available for orienting a model, saving a view, modifying a
model’s color and appearance, and for changing the lighting of Pro/ENGINEER’s
work screen.

INSERT MENU

The Insert menu provides selections for the creation of traditional Pro/ENGINEER
features (e.g., Protrusion, Hole, Datum Plane, Cosmetic Thread, etc.). Unlike
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previous versions of Pro/ENGINEER, datums can be created at anytime during
object modeling, including while sketching.

ANALYSIS

Options for finding assembly and part properties can be found under the Analysis
menu. As an example, the mass of a part can be obtained through the Model Analysis
option.

INFO MENU

The Info menu provides information about Pro/ENGINEER objects. Information
can be found on Parent-Child relationships, features, references, and geometry.
Messages, such as error messages created during regeneration failures, can be
displayed using the Message Log option. Additional information about failed
regenerations can be found using the Geometry Check option. A commonly used
option under the Info menu is Switch Dims, in which dimensions can be displayed
with numeric values or with dimension symbols. This option toggles between the
two dimension display modes.

APPLICATIONS MENU

The Applications menu will allow a user to switch between Pro/ENGINEER
modes and applications. As an example, a user may switch between Part mode
and Manufacturing mode.

UTILITIES MENU

The Utilities menu allows for the customization of Pro/ENGINEER’s interface.
Before Release 20, the Environment option was a common tool for changing the
work screen appearance. Many of the features found under the environment menu,
such as datum and model display, can now be found on the Toolbar. The Utilities
menu provides access to Pro/ENGINEER’s configuration file. Additional options are
available for customizing colors and for creating mapkeys.

WiNDOw MENU

The Window menu is used to manipulate Pro/ENGINEER windows. Windows can
be activated, opened, or closed. Within Pro/ENGINEER, multiple windows of
multiple parts can be open at once. To work in one menu, a user has to first activate
it. Opened windows are displayed under the Window menu, thus allowing a user to
easily switch from one object to another.

HELP MENU

Pro/ENGINEER utilizes a web browser to access help information. The Pro/Help
CD must be loaded before the full help option can be utilized. While Pro/Help
provides search capabilities for Pro/ENGINEER options, a context-sensitive help
option is also available. Use context-sensitive help to find information on individual
Pro/ENGINEER menus and options.

TOOLBAR

As shown previously in Figure 1-1, Pro/ENGINEER provides a toolbar for easy access to
frequently used options through the use of icons. By default, Pro/ENGINEERs initial tool-
bar is divided into five groups. Additional options can be added to the toolbar under the
Utilities menu.
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FILE MANAGEMENT

The file management group of icons is available for manipulating files. These icons (see
Figure 1-2) are

Figure 1=-2 File management icons

* New The New icon is used to start a new Pro/ENGINEER file.
* Open The Open icon is used to open a Pro/ENGINEER file.
¢ Save The Save icon is used to save a Pro/ENGINEER file.

* Save A Copy The Save A Copy icon is used to save a Pro/ENGINEER file as a
different name and to a different location.

* Print The Print icon is used to print or plot a Pro/ENGINEER object.

VIEW DISPLAY

The view display group of icons is available for modifying the display of Pro/ENGINEER
objects on the work screen. These icons (see Figure 1-3) are:

Figure 1-3 View display icons

* Repaint The Repaint icon is used to redraw the work screen.
e Zoom In The Zoom In icon is used to zoom in to a user-defined window.
¢ Zoom Out The Zoom Out icon is used to zoom out from the work screen.

» Refit The Refit icon is used to fit the extent of a Pro/ENGINEER object into the
work screen.

* Orient The Orient icon is used to orient a Pro/ENGINEER object on the work
screen.

* Saved Views The Saved Views icon is used to access saved views.

MODEL DISPLAY

The model display group of icons is available for changing the display of Pro/ENGI-
NEER objects. Only one of the four available icons under this group may be activated at
a time. These icons (see Figure 1-4) comprise the following:

HEEEE

Figure 1-4 Model display icons

* Wireframe The Wireframe icon displays a Pro/ENGINEER object as a wireframe.

* Hidden Line The Hidden Line icon displays a Pro/ENGINEER object with
hidden lines.
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» No Hidden The No Hidden icon displays a Pro/ENGINEER object without
hidden lines.

» Shade The Shade icon shades a Pro/ENGINEER object.
* Model Tree The model tree icon turns the display of the model tree on or off.

DATUM DISPLAY

The datum display group of icons is used to control the display of datums. This group (see
Figure 1-5) contains the following:

0 Wt ., ¥
LY R A
iz /= ‘® T®

Figure 1=-5 Datum display icons

e Datum Planes The Datum Plane icon is used to turn on or off the display of
Pro/ENGINEER datum planes.

* Datum Axes The Datum Axes icon is used to turn on or off the display of
Pro/ENGINEER datum axes.

* Point Symbols The Point Symbols icon is used to turn on or off the display of
Pro/ENGINEER datum points.

* Coordinate Systems The Coordinate Systems icon is used to turn on or off the
display of Pro/ENGINEER coordinate systems.

CONTEXT-SENSITIVE HELP

The Context-Sensitive Help icon is used to display help information on individual menu or
dialog box options. To use this help function, select the context-sensitive help icon (see
Figure 1-6); then select the menu item. Pro/Help will launch a web browser and display in-
formation about the selected item.

Figure 1-6 Contextsensitive help

FILE MANAGEMENT

Various options are available for manipulating Pro/ENGINEER files. Pro/ENGINEER’s
file management capabilities provide a wide range of functions for managing projects
and models. On first appearance, Pro/ENGINEER’s file open and save commands resem-
ble a Windows application. However, there are some significant differences between Pro/
ENGINEER’s file management and a Windows application.

» Pro/ENGINEER filename requirements are more restricted than Windows
application filenames.

» Saving a Pro/ENGINEER object creates a new version of the object each time the
object is saved. It does not override older versions.

* Pro/ENGINEER will not allow an object to be saved to a specific filename if
that filename already exists. Pro/ENGINEER will not save on top of an existing
file.
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FILENAMES

Pro/ENGINEER has different file extensions according to the mode being utilized. Table 1-1
shows file extensions based on five common Pro/ENGINEER modes:

Table 1=1 File extensions for Pro/ENGINEER modes

Mode Extension
Sketch *.sec.*
Part * prt.*
Assembly * asm.*
Manufacturing *mfg.*
Drawing *.drw.*
Format * frm.*

Notice the extra asterisk at the end of each file extension. This asterisk represents the ver-
sion of the file. The first time Pro/ENGINEER saves a file, this extra extension has a
value of 1. The second time a file is saved, a new file is created with a 2 as this value. The
third time a file is saved, a new file is created with a 3 as this value. Pro/ENGINEER cre-
ates a new object file each time a file is saved. If an object file is saved 10 times, 10 Pro/
ENGINEER files will be created. To delete the previous Pro/ENGINEER files, select
File >> Delete >> Old Versions.

Pro/ENGINEER file and directory names cannot be longer than 31 characters. Brack-
ets, parentheses, periods, nonalphanumeric characters, and spaces cannot be used in a file-
name. An underscore (_) may be used in a file name, though. Table 1-2 shows examples of
invalid and valid filenames.

Table 1-2 Invalid and valid filenames

Invalid Filename Problem Valid Filename
part one Space in filename part_one
part@11 Nonalphanumeric character part_11
Part[1_10] Brackets used in filename Part_1_10
MEMORY

When an object is opened, referenced, or created in Pro/ENGINEER, it is placed in mem-
ory. It remains there until it is erased, or until Pro/ENGINEER is exited. Also, when open-
ing an assembly, every part referenced by the assembly is placed in memory. Parts in active
memory are displayed in a window. Multiple parts, assemblies, and drawings can be in
active memory at once. This allows for ease of access between objects. Objects may also
be in session memory. Session memory is the condition where the object is in memory, but
not displayed in a graphics window.

WORKING DIRECTORY

Pro/ENGINEER utilizes a Working Directory to help manage files. The working directory
is usually the modeling point for all Pro/ENGINEER objects. When a new file is saved, it
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is saved in the current working directory, unless a new directory is specified. To change the
current working directory, from the File menu select Working Directory; then select the de-
sired directory as the working directory.

SAVING AN OBJECT

Various options are available for saving objects. New objects are saved by default in the
current working directory. If an object is retrieved from a directory other than the working
directory, the object is saved in its original directory. Additionally, selecting Save while in
a sketcher environment will save the section (*.sec.*) and not the object being modeled.
The following options are available for saving objects.

SAVE

This option saves an object to disk. When saving an assembly, all individual parts
that comprise the assembly are saved. When saving a drawing, the model used to
create the drawing is saved only when changes have been made to the object. While
sketching in a sketcher environment, the section under modification or creation is
saved, but not the object file. Pro/ENGINEER objects can be saved to a computer
hard drive, floppy disk, or zip disk.

SAVE A Copry

The Save A Copy option is used to either save an object as a new filename or to save
an object to a new directory. When an object is saved using this option, the original
filename is not deleted and is still the active model. Save A Copy practically creates a
copy of the object being modeled. Any changes made to the original object are not
reflected in the copied object.

BaAackup

The Backup option creates a copy of the object being modeled. The name of the
object cannot be changed with this option. Any saves of an object conducted after a
backup will be to the directory of the backup.

RENAME

The Rename option changes the name of a Pro/ENGINEER object. A suboption is
available for renaming the object on disk and in memory, or just in memory. When
renaming an object that already exists, all previous versions of the object are saved.

DELETE

Saving an object multiple times can create many versions of the object on disk. The
Delete option is available to purge old versions. Options are available for deleting
old versions or all versions of an existing object.

ERASE

Closing a window that contains a Pro/ENGINEER object does not remove it from
memory. The Erase command must be used to remove an object from memory. An
object that is referenced by another opened object cannot be erased. The Erase dialog
box shows all objects referenced by a selected object. Options are available for
erasing referenced objects from memory or for keeping them in memory.

ACTIVATING AN OBJECT

Multiple objects can be open at once within Pro/ENGINEER. Additionally, multiple win-
dows can be opened. To modify an object, its associated window must be activated. To
make a window active, use the Activate option found under the Window menu.



