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Getting Help

Every effort has been made to ensure the accuracy of this book and the contents
of its CD. If you do run into problems, please contact the appropriate source for help
and assistance.

Getting Help with The Book and Its CD

Microsoft Press provides corrections for books and companion CDs through the World
Wide Web at:

http.//www.microsoft.com/learning/support/books/

To connect directly to the Microsoft Knowledge Base and enter a query regarding a ques-
tion or issue that you may have, go to:

http://www.microsoft.com/learning/support/search.asp

Giving Feedback About the Book and Its CD

If you have comments, questions, or ideas regarding this book or its CD, or questions
that are not answered by querying the Knowledge Base, please send them to Microsoft
Press via e-mail to:

mspinput@microsoft.com
or via postal mail to:

Microsoft Press

Attn: Step by Step Editor
One Microsoft Way
Redmond, WA 98052-6399

Please note that product support is not offered through the above addresses.



Using the Book's CD

The CD included with this book contains all the practice files you'll use as you work
through the book’s exercises. By using the practice files, you won’t waste time creating
sample content with which to experiment—instead, you can jump right in and concen-
trate on learning how to create Web sites.

What's on the CD?

In addition to the practice files, the CD contains some resources that will really enhance
your ability to get the most out of using this book, including the following:

HTML color reference charts

HTML and XHTML templates

Bornus guides: “Designing for Accessibility” and “Designing for Usability”
Microsoft Office System Quick Reference eBook

Insider’s Guide to Microsoft Office OneNote 2003 eBook

Microsoft Computer Dictionary, Fifth Edition, eBook

Introducing the Tablet PC eBook

Complete HTML and XHTML Step by Step eBook

Minimum System Requirements

To complete the exercises in this book, you will need:

Computer/processor Computer with a Pentium 133-megahertz (MHz) or
higher processor; Pentium Il recommended.

Memory 64MB of RAM (128 MB recommended).

- Drives Hard drive and CD-ROM drive.

Hard disk Hard disk requirements will vary depending on configuration;
custom installation choices might require more or less hard disk space.

B 245 MB of available hard disk space with 115 MB on the hard disk where the
operating system is installed.

B  Anadditional 20 MB of hard disk space for installing the practice files.
Display Super VGA (800 x 600) or higher-resolution monitor with 256 colors.



Using the Book's CD

B  Pointing device Microsoft Mouse, Microsoft IntelliMouse, or compatible
pointing device.

B  Operating system Microsoft Windows 2000 with Service Pack 3 (SP3) or
Microsoft Windows XP Service Pack 2 or later.

®  Software Microsoft Office FrontPage 2003, Microsoft Office Word 2003, and
Microsoft Internet Explorer 6 or later.

Installing the Practice Files

You need to install the practice files on your hard disk before you use them in the
chapters’ exercises. Follow these steps.

1  Remove the companion CD from this book, and insert it into your CD-ROM drive.
Note An end user license agreement should open automatically. If this agree-

ment does not appear, open My Computer from the desktop or Start menu, dou-
ble-click the icon for your CD-ROM drive, and then double-click StartCD.exe.

Z  Review the end user license agreement. If you accept the terms, select the accept
option, and then click Next.
A menu will appear with options related to the book.

3 Click Install Practice Files.

4 Follow the instructions that appear.
T_he code samples are installed to the following location on your computer:

My Documents\Microsoft Press\HTML and XHTML SBS\

Using the Practice Files

Each exercise is preceded by a paragraph or paragraphs that list the files needed for that
exercise and explain any file preparation you need to take care of before you start work-
ing through the exercise.

The following table lists the practice file folders that you have installed from the CD. The
practice file folder for each chapter includes a Solutions subfolder containing finished
versions of the practice files used in that chapter.

Chapter : Folder Subfolder

Chapter 1: HTML and XHTML Basics 01Basics no subfolders

Chapter 2: Setting Up the Document Structure 02Structure CreatingParagraphs
SpecifyingKeywords

PublishingFiles

xXiv



Using the Book's CD

Chapter

Folder

Subfolder

Chapter 3: Formatting Text by Using Tags

03Format

CreatingHeadings

.ApplyingBold

ApplyingSuperscript
UsingMonospace
FormattingQuotes
ConfiguringSettings

Chapter 4: Using Lists and Backgrounds

O4Lists

NestingLists
CreatingGlossary
InsertingCharacters
InsertingLines
ChoosingColors
Specifyinglmages

Chapter 5: Creating Hyperlinks and Anchors

05Links

CreatingHyperlinks
LinkingEmail
CreatingAnchors
LinkingOther

Chapter 6: Introduction to Style Sheets

06Styles

ConstructingRules
CreatingNested
CreatingClasses
StylingHyperlinks
CreatingExternal

Chapter 7: Formatting Text by Using Style Sheets

07Text

SelectingFont
SelectingSize
ApplyingBold
ApplyingStrike
CreatingSpan
AdjustingSpacing

Chapter 8: Formatting Paragraphs by Using Style
Sheets

08Paragraphs

Indenting
AddingBorders
SettingAlignment
AdjustingHeight

Chapter 9: Displaying Graphics

09Graphics

Insertinglmages *
Clearinglmages
Sizinglmages
CreatingHyperlinks
UsingThumbnails
UsingAlt




Using the Book's CD

Chapter

Folder

Subfolder

Chapter 10: Creating Navigational Aids

10Navigation

CreatingTextBar
CreatingGraphicBar
CreatinglmageMap
Redirecting

Chapter 11: Creating Tables

11Tables

CreatingTable
SpecifyingSize
SettingWidth
SpanningCells
UsingTables

Chapter 12: Formatting Tables

12FmtTables

ApplyingBackground
ApplyingBorders
ChangingPadding
CreatingGroups

Chapter 13: Creating Division-Based Layouts

13Divisions

CreatingDivisions
PositioningDivisions
FormattingDivisions

Chapter 14: Creating User Forms

14Forms

CreatingForms
CreatingButtons
CreatingLists

Chapter 15: Using Frames for Layout

15Frames

CreatingFramesets
CreatingComplex
SettingTargets
FormattingFrames
Creatinglnline

Chapter 16: Incorporating Sound and Video

16Multimedia

RecordingSound
LinkingSound
EmbeddingSound
EmbeddingVideo

Chapter 17: HTML and Microsoft Word

17Word

SavingFiles
CreatingPages
FormattingPages
CreatingTables

Chapter 18: HTML and Microsoft FrontPage

18FrontPage

FromTemplate
FromScratch
ApplyingTheme
CreatingNav




Using the Book's CD

After you finish working through this book, you should uninstall the practice files to
free up hard disk space.

On the Windows taskbar, click the Start button, point to Settings, and then click
Control Panel.

Double-click the Add/Remove Programs icon.

In the list of installed programs, click HTML and XHTML Step by Step, and then
click Add/Remove.

Click Yes when the confirmation dialog box appears.



Conventions and Features

You can save time when you use this book by understanding how the Step by Step series
shows special instructions, keys to press, buttons to click, and so on.

Convention

This icon indicates a reference to the book's companion CD.

BE SURE TO These words are found at the beginning of pa/ragraphs preceding or following
step-by-step exercises. They point out items you should check or actions you
should carry out either before beginning an exercise or after completing an
exercise.

USE These words are found at the beginning of paragraphs preceding step-by-step

OPEN exercises. They draw your attention to practice files that you'll need to use in
the exercise.

CLOSE This word is found at the beginning of paragraphs following step-by-step
exercises. They give instructions for closing open files or programs before
moving on to another topic.

i Numbered steps guide you through hands-on exercises in each topic.

2

@ A round bullet indicates an exercise that has only one step.

Troubleshooting These paragraphs show you how to fix a common problem that might prevent
you from continuing with the exercise.

Tip These paragraphs provide a helpful hint or shortcut that makes working
through a task easier.

Important These paragraphs point out information that you need to know to complete a
procedure.

Note These paragraphs provide supplementary or related information.

[e+(c) A plus sign (+) between two key names means that youmust hold down the

first key while you press the second key. For example, “press [ev)+(C]" means
“hold down the (o) key while you press the (€] key."

user interface
elements

In exercises, the names of program elements such as buttons, commands, and
dialog boxes.

user input

Anything you are supposed to type.

glossary terms

Terms explained in the glossary at the end of the book.
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Quick Reference

Abbreviations used in command syntax:

address An e-mail address

classname A class name you define

color A color expressed as a name, a hexadecimal value, or an RGB value
filename.ext A filename and extension

idname An ID name you define

n Adigit

name A name assigned to a variable or anchor point
rule Astylerule

tag Any tag (p, hl, h2, and so on)

text The text as it should appear onscreen

url Avalid URL

value The value of a style rule

Chapter1 HTML and XHTML Basics

Page 9 To open a Web page in Notepad
1 On the Start menu, point to All Programs, point to Accessories, and then click
Notepad. '
2 In the untitled Notepad window, on the File menu, click Open.
3 Navigate to the folder containing the file.
4 Click the Files:of type arrow, and then click All Files.
5  Inthe Open dialog box, click the file, and then click Open.
Page 12 To preview a Web page in Microsoft Internet Explorer
L On the Start menu, click Internet Explorer.
2 On the File menu, click Open.
3 Click the Browse button, and then browse to the folder containing the file.
4  Click the file, and then click Open.
5 ClickOK.
Page 15 To save changes to a file in Notepad

@  On the File menu, click Save.

xxiii



Quick Reference

Chapter 2 Setting Up the Document Structure

T

Page 20 To specify a document t

<!DOCTYPE HTML PUBLIC "-//W3C/DTD HTML 4.01 Transitional//EN" "http://www.w3.org/
TR/htm14/Toose.dtd">

Page 20 To specify a document type of trans

<!DOCTYPE HTML PUBLIC "-//W3C/DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/
TR/xhtm11/DTD/xhtml1-transitional.dtd">

Page 21 To create the HTML section
<html></htm1>

Page 21 To create the Head section (within the HTML section)
<head></head>

Page 21 To create the Body section (within the HTML section)
<body></body>

Page 23 To create a body paragraph
<p>text</p>

Page 23 To create a line break
<br />

Page 26 To create a page title {within the b section)
<title>text</title>

Page 26 To create metatag keywords (within the Head section)

<meta name="keywords" content="wordl, word2, word3" />
Page 26 To redirect the page to another URL
<meta http=equiv="refresh" content="n; url="url" />

where n is a number of seconds of delay and url is the URL of the site to which to redirect.
Page 28 To set up a Web location for publishing a Web site

1 On the Start menu, click My Network Places.

2 In the Network Tasks area, click Add a network place, and then click Next.
3 Click Choose another network location, and then click Next.
4

Type the Web address to which you want to connect, including the http:// at the
beginning, and then click Next.

5  If prompted, enter the user name and password you have been assigned for the
server, and then click OK.

&

Type a name by which to refer to this network place, and then click Next.
7 Click Finish.

xXxiv



Quick Reference

Page 28

BEEE ?» e e

On the File menu, click Save As.

On the Places bar, click My Network Places, or click the Save In list, and then click
My Network Places.

Double-click the network shortcut to the server.

If prompted, enter the user name and password required to connect to the server,
and then click OK.

Browse to the folder in which you want to save the file.

If you want to see the files that are already there, click the Save as type arrow, and
then click All Files.

Click Save.

Chapter 3 Formatting Text by Using Tags
Page 36 fo create headings (any of six levels)

<hl>text</h1>
<h2>text</h2>
<h3>text</h3>
<h4>text</h4>
<h5>text</h5>
<h6>text</h6>

Optional argument:

align= Sets horizontal alignment; valid values are 1eft, right,
center, and justify.

Page 38

<b> text</b>
Page 38

<i>text</i>

Page 40

Page 40

Page 41

<tt>text</tt>
or

<kbd> text</kbd>
or

<code> text</code>



Quick Reference

Page 41

Page 48

Page 52

Page 52

Chapter 4
Page 60

Page 60

or

<samp> text</samp>

To use preformatted text
<pre>text</pre>

To create a block quotation
<blockquote>text</blockquote>

Optional argument:

Cite= Specifies the URL source of the quote.

To change text viewing size in Internet Explorer

@  On the View menu, point to Text Size, and then click the size you want.
To change the default font for Web text in Internet Explorer

L On the Tools meny, click Internet Options.

Z  On the General tab, click the Fonts button.

3 In the Web page font list, click the font you want.

4 In the Plain text font list, click the font you want.

5  Click OK in both the Fonts dialog box and the Internet Options dialog box.

Using Lists and Backgrounds

To create an ordered (numbered) list

<ol1>
<li>text</1i>
<li>text</1i>
</o1>

Optional arguments:
type= Specifies the number style; valid values are decimal, decimal-

leading-zero, lower-roman, upper-roman, lower-alpha, upper-
alpha, and none.

start= Specifies the starting number; deprecated.

To create an item within an ordered or unordered list
<li>text</T1i>
Optional argument:

value= Specifies the number to be assigned to the list item (for
ordered lists only); deprecated.



