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INTRODUCTION

This book teaches the fundamentals of using
Macromedia Director, an exciting and chal-
lenging program for creating animation and
multimedia productions for CD-ROM, your
local network, or the Web.
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With this Director 7 Visual QuickStart Guide
you learn how to perform all the steps
involved in creating Director projects, or
movies as most people call them. The book
covers how to:
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Create and assemble cast members in
Cast windows.

Animate cast members on the stage.
Build a movie frame-by-frame in the score.

Create and edit cast members in the Paint
window or new Vector Shapes window.

Control movie playback, set scene
transitions, alter color palettes, and add
Interactive controls to your movies using
drag-and-drop behaviors.

Produce a Shockwave-format file for
distributing a movie on the Internet.

Use Xtras, add-on modules that provide
extra features.

Introduce yourself to Lingo, Director’s
scripting language.
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INTRODUCTION

Introduction

About This Book

In the Visual QuickStart Guide format, this
book provides clear instructions, supported
by many illustrations. Where necessary,
you ll find concise explanations—without
any distracting fluff. The idea is to get you up
and running as quickly as possible through
practical examples.

How to Use This Book

If you have used any other Visual QuickStart
guides, you will find this book familiar. Each
chapter offers a series of step-by-step
instructions for completing essential tasks.
As you work through the tasks, you gain an
understanding of the program features and
how to exploit them. Occasional tips provide
hints for working efficiently, and illustrations
demonstrate the techniques clearly.

The chapters unfold sequentially. The early
chapters assume that you don't know any-
thing that [ introduce in a later chapter. You
can use this book with the index to find out
how to do something, but it’s set up to make
it easy to learn from scratch as you go through
the book from chapter to chapter. You could
skim some of the later chapters in the book
because they detail how to do perform tasks
that not all Director users need, but I recom-
mend that you follow chapters one through
five in order. Those first five chapters build
on each other to help you quickly learn how
to make and play a simple Director movie.

New in This Edition

This new edition of the book covers the latest
version 7 features. Like the program itself,
this edition of the book is completely updated
to make it even easier to use than previous
versions. Also, for the first time both the
Macintosh and Windows versions of the pro-
gram are covered in this one book, although
you still have to buy two versions of the pro-
gram to make movies for both platforms.
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Introduction

About Conventions in
This Book

Different computer books use terms differ-
ently, so it’s important to know how this
book uses common terms.

Click means pressing down and releasing
the Macintosh mouse button, or pressing
down and releasing the left mouse button
on Windows.

Drag means to hold the mouse button down
and then move the mouse. You release the
mouse button when you finish dragging.

Menu Commands

This book writes menu and command choices
in the form of Menu name > Command >
Subcommand. For example, if I need to tell
you to choose Media Element from the
Insert menu and then to select Bitmap from
the submenu that pops out to the side, I can
save us all a lot of trouble if I say instead,
"Choose Insert > Media Element > Bitmap.”

Keyboard Shortcuts

This book scatters keyboard shortcuts for
commands sparingly throughout the book.
There are two reasons for being stingy with
the keyboard shortcuts in the step-by-step
Instructions:

¢ [t’s distracting to have a choice of how
to do something when you're trying to
learn techniques.

¢  We all have so many PINs and passwords
to remember that it's smart to be selective
about what new things we commit to
memory. Once you have worked with the
program, you will know which commands
you use so repeatedly that it's worth the
trouble to learn the shortcut. Then refer
to Appendix B for a handy reference to
the menus and their keyboard shortcuts.
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INTRODUCTION

Introduction

About Cross-Platform
Issues

Director 7 for Windows and Director 7 for
Macintosh differ very little. That's why it
makes sense to produce a single book that
covers both versions of the program.

Illustrations

Figures that illustrate the tasks in this book
come from both Mac and Windows versions
of Director 7. Only a few elements of the
program actually offer different choices in
the two versions, and the other differences
in the figures are merely cosmetic.

Command and Modifier Keys

Modifier keys for keyboard commands differ
on the Mac and on Windows. Where I use
the command and modifier keys (such as
Shift, Alt, and Option), I say which keys to
look for. Here's an example: “"Hold the Alt key
(Windows) or Option key (Mac) while drag-
ging the Lasso.’

The Shift key works the same way on both
types of computers.

The Command key on the Mac is the one that
has the apple and cloverleaf symbols on it.

Features That Differ on Mac
and Windows

Some techniques are performed differently on
Windows and the Mac. Thus, in a few places
a step has one method for Mac and one for
Windows. Those steps are clearly labeled
(and there aren’'t very many of them).

Even rarer are tasks that differ completely on
the two types of computers. In those cases
['ve written totally different instructions, and
[ tell you about it in the heading for the task.
For example, only the Macintosh can record
sounds into Director, and so there is a task
called “To record sounds directly into
Director (Mac).”
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DIRECTOR BASICS

Macromedia’s Director is an extensive multi-
media development tool. Use it to create
animation, interactive movies, marketing
presentations, technical simulations, and
even full-scale commercial productions such
as entertainment titles for CD-ROM and

the Web.

Director’s powerful tools take some getting
used to because they work differently than any
other program you may have used. (If you've
done sound-sequencing or digital video edit-
ing, you might be in more familiar territory.)

Let’s begin with a visual overview of the
program so you can see how its parts work
together. If you're new to Director, you'll find
it worthwhile to take a few minutes to go
through this chapter even if you're itching

to get started. And you'll be rolling up your
sleeves and plunging into the program before
the end of the chapter.

SJISvg ¥0Ld3I(]

In this chapter you'll learn how to open the
program, start a new movie, update movies
produced with earlier versions of the program,
use the Help system, set preferences, and
find shortcuts. You'll also see an overview of
the workflow for completing a project.

[f you're someone who begins to learn a
program by cruising through all the menus,
turn to Appendix B, Menus and Shortcuts,
for a complete array of the Director menus.




ABOUT THE STAGE

Chapter 1

About the Stage

The Director stage (Figure 1.2) serves as the
window to the visual elements of a Director
movie. Naturally, the stage is empty when
you first open the program; it’s your blank
slate, awaiting your decisions about what to
include in the movie.

The toolbar (Figure 1.1), which is nearly
always visible while you work with Director,
provides quick access to the most important
Director commands.

New

Cast Import Save All Undo Copy Member Rewind Play Window

Find Cast

Sprite

/nspector
cast P

Text
Paint Ly

Window

Script
Window

View Open
Movie

Save

Save As

Shockwave

Movie

cut Paste

Exchange
Cast
Members

Figure 1.1 The toolbar provides buttons that act as
handy shortcuts to Director commands.

Stop

Stage Score

Vector Behavior

Window Shape Inspector
Library Window Message
Palette Window

Figure 1.2 The stage opens empty when you first launch Director. Here you
compose elements of your movie and play it back for review. On the stage

you control the position of visual elements within the playback area.

The stage
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Director Basics

About Cast, Score, and
Stage Interaction

You build a Director movie by organizing cast
members (Figure 1.3) in the score (Figure
1.4). This is the only way to control nonvisual
elements that you can't see on the stage
(Figure 1.5). You also use the score to set
how long things remain active in the movie.

Figure 1.3 Cast members, stored in
Cast windows, are the multimedia
elements that comprise a movie.
Cast members can be images,
animation sequences, text, sounds,
GIF animations, transitions,

and more.

Off to the

|IRaces!

§ | {QPiano musie s

Figure 1.4 The score shows a
detailed grid that represents all the
details of a movie—over time.
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Figure 1.5 You arrange images

of the cast members in position on
Director’s stage to set the scene for
one frame of the movie, which is a
lot like a single frame of a
Hollywood movie, or a single
photograph in a roll of film. Then

you rearrange the cast manually

or with Director’s commands to
animate the scene over a sequence
of frames.
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ABOUT SPRITES AND CAST MEMBERS

Chapter 1

About Sprites and T spe label -

When you add a cast member (Figure 1.6)
to a frame, you don't add a bulky copy of the
cast member; you add an object called a sprite
(Figure 1.7). The sprite points to the cast
member but takes up very little space on disk
and in computer memory, so you can make a
movie of many frames populated with many
sprites without overflowing your hard disk.

You can base many sprites on a single cast
member. Each sprite of a cast member can
have unique properties that define how,
where, and when the cast member appears in
a movie. You can think of a cast member as a score to see that all five of the sprites
template, and a sprite as an instance of the come from the shuttle cast member.
cast member. You can build a scene with only

a few sprites (Figure 1.8).

] [« ] e smetee ] |

A e AR R S it TR . parhy

Figure 1.6 You can create many sprites in a movie
from a single cast member. They can all look alike,
or you can change their appearance and add effects
so they look very different.
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Figure 1.7 All these shuttle
| sprites come from the same
e e ey cASE member.




Director Basics

New Window
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QuickTime 9 |
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v Message #EM

Debugger B
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Figure 1.9 A checkmark
along a Window menu item
means that its window is
open. A diamond indicates
the active window.

Playback Control Panel

Message window
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About Director Windows

In addition to the stage, score, and Cast
windows, Director provides work windows
for specific tasks that you perform as part of
making a movie. The Window menu lets you
access the work windows and tools of Director.
Later chapters explain how to use these tools.

Paint window

ol . *

[ Untitied-1 ¢l

Angle : =1 X Offset

e e B | R B oy 4 h
i et i T N oy W

Vector Shape window

Field Text window
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Field Text|
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Text window
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ABOUT DIRECTOR INSPECTORS

Chapter1

About Director Inspectors

In addition the menus, dialog boxes, and
toolbars that probably seem familiar if you've
worked with other Mac or Windows pro-
grams, Director has inspectors. Inspectors
give you a glimpse of the details of elements
of a Director movie.

You access inspectors through the Window
menu (Figure 1.10).

To open an inspector:

¢ Choose Window > Inspectors >
Inspector name.

MENYmGOw
v Toolbar  CO®B
Tool Palette %7
v Library Palette
Inspectors =
v Stage X1 TS oS
Control Panel 882
Markers O8BM
i b R e,
AL
Paint )
Vector Shape ORY
Text %6
Field #8
QuickTime #9
Color Palettes "C37
Script %0
Message M
Debugger ®°
| WALEREr E’aL_] Figure 1.10

Figure 1.11 Use the
Sprite Inspector to
confirm sprite settings
or to control many of
the properties used to
animate sprites.

s o e o S e e X e
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Figure 1.12 Use the Text Inspector to check text
settings of to adjust some of the text formatting
properties. This is also where you set text to act as a
hyperlink (see Chapter 11, Adding Text).




