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Preface

Computers have revolutionized the analysis of sequencing data. It is
unlikely that any sequencing projects have been performed in the last few
years without the aid of computers. Recently their role has taken a further
major step forward. Computers have become smaller and more powerful and
the software has become simpler to use as it has grown in sophistication. This
book reflects that change since the majority of packages described here are
designed to be used on desktop computers.

Computer software is now available that can run gels, collect data, and
assess its accuracy. It can assemble, align, or compare multiple fragments,
perform restriction analyses, identify coding regions and specific motifs, and
even design the primers needed to extend the sequencing. Much of this soft-
ware may now be used on relatively inexpensive computers. It is now possible
to progress from isolated DNA to database submission without writing a single
base down.

To reflect this progression, the chapters in our Sequence Data Analysis
Guidebook are arranged, not by software package, but by function. The early
chapters deal with examining the data produced by modern automated sequenc-
ers, assessing its quality, and removing extraneous data. The following chap-
ters describe the process of aligning multiple sequences in order to assemble
overlapping fragments into sequence contigs to compare similar sequences
from different sources. Subsequent chapters describe procedures for compar-
ing the newly derived sequence to the massive amounts of information in the
sequence databases.

The acquisition of sequence data is now only the beginning of the pro-
cess of analysis. Therefore, the later chapters of Sequence Data Analysis Guide-
book are dedicated to software that allows the data to be examined for specific
“features.” This includes performing restriction analysis, searching for open
reading frames, calculating the translation products of open reading frames,
and performing detailed analyses of the “proteins.” The software described is
sophisticated enough to produce detailed graphic representations of the data
showing features such as restriction sites, coding regions, and promoters. It is
also able to create simulations of electrophoretic patterns produced by diges-
tion of DNA or protein.
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The design of primers either for continued sequencing or manipulation
of the analyzed sequence by the polymerase chain reaction is an important
part of the analysis process. Several programs designed to aid primer design
are described.

Once the sequence has been analyzed as fully as possible, the data is
likely to be published. To aid in this, several of the packages described allow
the production of complex, publication-quality figures. Since many journals
now insist that published sequences be submitted to one of the major databanks,
the final chapter deals with the various ways now available to achieve this.

Sequence Data Analysis Guidebook assembles examples of how optimally
to use some of the most popular software available today. The packages dealt
with have been selected because they are in common use in many sequencing
laboratories around the world, and should, therefore, represent a useful reference
source for many researchers.

Each of the authors has used these packages extensively: The Notes sec-
tion found at the end of each chapter is a key feature of this book and contains
information derived from their invaluable personal experience.

I would like to acknowledge the efforts of all the contributing authors.

Simon R. Swindell
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GenedJockeyll

Entering and Editing Sequences

Phil Taylor

1. Introduction

Entering sequence by hand is a tedious and error-prone process. In general,
if the sequence that you need is available in any electronic form, you should be
able to import it into GeneJockeyll without having to retype the data. For
example, most sequences published in research papers are normally accompa-
nied by a GenBank/EMBL accession number, which allows you to retrieve the
sequence from the GenBank CD-ROM or from a remote networked database.
If, however, you have no option but to type the required sequence (for
example, if you are reading sequence by hand from a manual sequencing gel),
GenelJockeyll provides powerful facilities to do so, and to check the accuracy
of the entered data. Sequence data in GeneJockeyll is simple text, displayed in
capitals, and behaves just as text does in any word processor. All the standard
editing commands act in the way in which you expect them to act, and you may
use fonts, styles, and colors to draw attention to parts of your sequence, just as
you would when editing ordinary text.

2. Materials

1. Hardware: GeneJockeyll requires a Macintosh with ColorQuickdraw in ROM
(this excludes the Macintosh plus [and older machines], the SE, the PowerBook
100, and the Macintosh Portable). The program also requires system 7.0 or later,
and at least 2 Mb of available memory. A color display capable of showing 256
colors is helpful but not essential.

2. Software: For the operations described in this chapter, you need only the
GeneJockeyll program itself. For operations described in later chapters, you will
need some additional files supplied with the program. You would normally install

From: Methods in Molecular Biology, Vol. 70: Sequence Data Analysis Guidebook
Edited by: S. R. Swindell Humana Press Inc., Totowa, NJ
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Fig. 1. Anatomy of a GeneJockeylI sequence window.

GeneJockeyll on your hard drive by simply copying all the files supplied into a
single folder. When running on a Power Macintosh, the GeneJockey Helper file
should be present in the same folder. The native-code resources in this file run
about ten times faster than the code in the main program, and since multiple align-
ment is a time-consuming process, the extra speed is very helpful. GeneJockeylII is
licensed for use only on a single-user basis, but is not copy-protected.

3. Methods
3.1. Sequence Entry

1

Start up the program by double-clicking on the GeneJockeylI icon. The program
offers three kinds of windows in which you may enter and edit text. For this
reason, the New command in the File menu is hierarchical, offering you the
choice of a new nucleotide sequence window, peptide sequence window, or a plain
text window. We will start by opening a nucleotide sequence window and enter-
ing a DNA sequence (see Note 1). Fig. 1 shows a nucleotide sequence window.
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2.

10.

Use the New > Nucleotide sequence command to open the window. Note that the
window title is Untitled 1. As is usual with Macintosh programs, the window will
not be given a title until you save it to disk (see Note 1).

Use the Save as... command from the File menu to save your new window before
you start typing.

Give the file a suitable name for the sequence you are going to enter.

When the file is saved, click on the empty sequence box to place the insertion
point at the top left of the box.

Start typing your DNA sequence. Note that the program converts text that you
type into this box to uppercase (see Notes 2,3).

Next, select Speak on Entry from the Edit menu. Continue typing. Each time you
hit a key, the machine will speak the corresponding letter. This is very helpful if you
are not a touch typist, because it means that you do not have to look at the screen to
check what you type. You can turn this facility off again using the same command.
Select Tidy up to format the sequence into blocks of 10 nucleotides (see Note 4).
Once you have typed in a few lines of sequence use the Save command to update
the disk file. It is always a good idea to save sequences frequently when typing,
in case of accidents. You should make sure your sequence is saved before carry-
ing out the operations in the next paragraph.

Type a few more bases and look at the Revert to Original and Undo commands
(see Notes 5,6).

3.2. Switching Between Circular and Linear Sequences

1

2

Of the three buttons at the center of the screen, the left-hand button currently
reads Linear. When you click on it, the legend changes to Circular. The button
toggles between these two states, and the legend indicates the current conforma-
tion of the sequence. The difference between linear and circular sequences is for
the most part trivial, affecting only the restriction enzyme analysis, in which it is
important to deal correctly with restriction sites that span the origin of circular
sequences (i.e., where part of the site is at the top left of the display at position 1,
and the other part at the very end).

Click on the button again to return the sequence to the linear state.

3.3. Changing the Origin Point

1.

3
4.

Click on the Set Origin button. You will see a dialog box that asks you for the
number of the first nucleotide in the sequence and tells you that you may enter
any number between 32 and —32 K, except zero (see Note 7).

Enter a small negative number, such as —20, and click on OK. The First Nt:
legend at center left now reads —20 to remind you of the current numbering, and
if you run the cursor along the top line of the sequence, you will see that the
numbering jumps from —I to +1 without using zero.

Click on the Set Origin button again and set the origin back to 1.

Now, make the sequence circular, and if you have made any changes, save the
sequence again. (If you can not remember whether you have made any significant
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changes, pull down the File menu and look at the Save command. If it is disabled
then you do not need to save.)

Now use the Set Origin button again. The effect of changing the origin of a circu-
lar sequence is quite different, since by convention the origin of a circular sequence
is always shown at the top left of the display. If you set the origin to —20, the
sequence will be rotated so that the last 20 nucleotides are brought to the begin-
ning, with the nucleotide that was twentieth from the end of the sequence dis-
played at the top left, and numbered 1. Remember that there is no Undo command
for this, so it is a good idea to make sure the sequence is saved in case you make
a mistake with the numbering. You can then use the Revert command to restore
the original display. The effect of circularizing a linear sequence whose origin is
not the first nucleotide displayed is similar, and the same caution applies here.

3.4. Verifying the Sequence

Entry of sequences at the keyboard is an error-prone process, and if you

wish to be certain that the sequence you have entered is correct it is necessary

to

use some form of verification. GeneJockeyll offers you two methods of

verifying sequences: Verify by Speaking and Verify by Typing. Both com-
mands are found in the Edit menu.

1.

2.

h: s, 10

First, click at the top left of the sequence to set the insertion point at the begin-
ning (or just before the part of the sequence you wish to check).

Select Verify by Speaking. The computer will speak the first 10 bases of
the sequence, permitting you to check that you have entered them correctly. Hit the
space bar or any other printing key to start reading the next 10 bases. If you wish to
move quickly around the sequence, use the left or right arrow keys to move forward or
back 10 bases, or the up or down arrow keys to move one line up or down (see Note 8).
Set the insertion point back to the beginning of the section you wish to check.
Select Verify by Typing (see Note 8).

Start retyping the sequence. As you type each base, the selection moves one place
forward. If you type a base that does not match the sequence you entered origi-
nally, the machine will beep and the selection will not move on.

In order to correct the error, type Command-period and the machine will return
control to you with the incorrect base already selected for changing.

Type the correct base then reissue the Verify by Typing command to continue
verification (since this is a keyboard-orientated operation you will find it quicker
to use the Command-T equivalent to restart verification). As before, you may use
the arrow keys to move around rapidly during verification, and the machine will
exit from the mode automatically when you reach the end of the sequence.

3.5. Annotating Sequences

You can insert notes and comments on your sequence in the upper text box

of the window. Only one of the text boxes is active at any time, indicated by the

fla:

shing insertion point.
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12. Set the insertion point on the cut site, i.e., between the G (at 701) and the following A.

13. Click on the test sequence window to bring it back to the front.

14. Select the whole sequence by means of the Select All command from the Edit
menu. (You could also do this by dragging across the whole sequence, or by
setting the insertion point at the beginning and shift-clicking at the end.) So that
we will be able to identify the insert when we have made the construct, it is a
good idea to label it now.

15. Use the Color... command from the Text menu to put the sequence into a con-
trasting color (see Note 10).

16. Next, copy the entire sequence onto the clipboard by means of the Copy com-
mand from the Edit menu.

17. Bring the vector sequence window back to the front. If you do this by clicking on
it, be careful to click only once, or you may shift the insertion point from the
place where you left it. Check that it is still after the G at 701.

18. Paste the test sequence in using the Paste command from the Edit menu.

19. Click on the Tidy up button to reformat the sequence.

20. Save it under a suitable name.

There—you have just ligated a test sequence into a vector—I bet you wish it
was that simple in the real world!

3.7. Inverting Sequences

Suppose that we have only the construct sequence to work with, but we
decide that the wrong strand of DNA has been inserted into the vector, and we
need to take it out, invert it (i.e., generate the opposite strand), and put it back
again. First, we have to select the insert, which is now in the middle of the
pBluescript sequence. We know where the beginning is, just after the EcoRI
site at 701, so we only need to locate the end. We could find that numerically
by adding the length of the test sequence to 701, or we could simply scroll
down the screen to see where the color changes, but we will search again for
the second EcoRlI site, which now marks the end of the insert.

1. Set the insertion point at the beginning of the sequence

2. Select the Find Same command. This simply repeats the previous search, find-
ing the original site.

Repeat the Find Same command to find the second EcoRI site.

Set the insertion point just before the G of the second site.

Scroll back to the first site at 701. Hold down the shift key while you click after
the C of the first site. The whole of the insert will then be selected. (In
GeneJockeyll, the cursor display remains active while you drag, so you could
also just drag across the part of the sequence that you want, watching the num-
bers to see when you get to the right place. Yet another alternative would be to
use the Select... command from the Find menu and specify numerically the region
of sequence you want selected.)

Ll oo
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13.
14.

Copy the insert onto the clipboard.

Use the New > Nucleotide Sequence command to generate a new sequence window.
Paste the sequence into it and Tidy it.

Select Invert from the Modify menu. The program opens a new window con-
taining the inverted sequence (see Note 11).

Use Select All to change the color as before, if you wish.

. Copy the entire sequence.

Pull the window containing the construct back to the front. Since we now have
several windows open, it is easier to do this by means of the Windows menu than
by trying to find it by moving the windows around on the screen. The part of the
sequence that represents our original insert is still selected.

Paste the inverted sequence, and it will replace the original.

Tidy up the sequence.

We are now finished with the windows that we currently have open, so close

them all. To do this, hold down the Option key while clicking in the close box
of the front window. The program will close all the windows in turn, prompt-
ing us as it does so to save any new work.

4. Notes

1.

Using the New command offers three alternatives. One is for creating a new nucle-
otide sequence. The second is for creating a new peptide sequence. Peptide sequen-
ces are entered in precisely the same way as nucleotide sequences, and a peptide
sequence window looks just like a nucleotide sequence window, the only obvious
difference being that the origin prompt at center left reads “First AA:” rather than
“First Nt:.” You will notice some differences when you come to use the modifica-
tion and analysis commands, however, since different menu commands will be
enabled depending on what type of window is foremost on the screen.

Peptide sequences are entered in single letter code and represented in uppercase
characters only. There are no wildcard characters. The type of window you choose
specifies whether the program will treat the sequence as DNA or protein, and there is
very little to prevent you from entering the wrong kind of sequence into a window
(there is no way for the program to distinguish between a short DNA sequence and
the equivalent set of characters representing a peptide consisting entirely of alanine,
cysteine, glycine, and threonine, for example), so be careful when using the New
command to ask for the correct window type for the sequence you intend to enter.

A third type of window that may be obtained with the New command is a plain
text window. This has a single scroll bar and is 80 characters wide. There is a title
area at the top that holds a single line of text and initially reads “New text win-
dow.” This title string is not directly editable, but may be changed via a dialog
box obtained by clicking in this area. The remainder of the window acts as a plain
text area, and is useful for general purpose editing. Many of the analyses. that
GenelJockeyll performs display their results in text windows, and you may edit
such results before printing or saving them.
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2. GeneJockeyll only handles sequences consisting of uppercase symbols. Note that

when you reach nucleotide number 10, and any multiple of 10 thereafter, the
program will automatically insert a space or return so that the sequence is dis-
played in blocks of 10. In a nucleotide sequence window, you may use the sym-
bols A, C, G, and T, plus the standard degenerate symbols that are used to
represent the case in which a particular position may be occupied by more than
one base. U is not a legal character, so RNA sequences should be entered as
DNA. If you type an illegal character you will get a dialog box displaying the
complete list of these characters. For example, type in an X to see this. You can
also see the display of permitted degenerate codes at any time by selecting the
Show Wildcards... command from the Edit menu. You can dismiss the
Wildcards dialog either by clicking on the Cancel button or by clicking on any of
the buttons that display the degenerate codes; in the latter case the dialog causes
that code to be inserted into the sequence at the current selection point.

When entering DNA sequences you will make extensive use of the A, C, G,and T
keys, and it is most convenient to have these keys close together so that you can enter
the data with one hand and not have to look at the keyboard. Use the Re-Assign
Keys... command from the Edit menu to do this. Because I am right-handed, I nor-
mally reassign the keys U, I, O, and P to give me A, C, G, and T, respectively. This
has the advantage that none of U, I, O, or P are degenerate codes, so I will never want
to use them for their original symbols within a DNA sequence, and they are close
enough on the keyboard to the delete key that if I make a mistake I can backspace
over it without taking my eyes off the gel or sequence from which I am reading. If
you wish your keyboard always to work in this way, you should click on the Set
Default checkbox before clicking on OK in the dialog. To return the keyboard to
normal you should click on the Standard Layout button. The reassigned keyboard
only applies to DNA sequences; the keyboard will operate normally when you type
ordinary text into the comments area of a sequence window or anywhere else.

You have probably noticed by now that if you move the mouse cursor across the
sequence box the number of the nucleotide beneath the cursor is continuously
displayed at center left. This is very helpful for locating a particular nucleotide
by number. The calculation of the number does, however, depend on the sequence
being formatted correctly in regular blocks of ten. Some operations destroy this
regular format, and the function of the Tidy up button is to restore order in these
cases. For example, suppose you wished to insert an extra block of sequence in
the middle of your existing sequence. Place the insertion point in the middle of
the sequence by clicking on it. Now type in a few nucleotides. The resulting
disorder would not affect any analyses that you later ran on this sequence, since
all the analyses ignore the presence of space and return characters, but it looks
untidy and spoils the operation of the cursor position display. Click on the Tidy
Up button to put the sequence back into regular columns. It would have been
possible to make the program tidy the sequence after every keystroke, but it would
have slowed the operation of the program to an irritating extent, especially when
inserting residues near the beginning of a long sequence.
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5.

If you now wish to restore your sequence to its original state, select the Revert to
Original command from the File menu. This returns the window to the state it
was in when you issued the last Save command, checking with you first to see if
you really want to discard any changes made since then.

Another way to reverse any change you have made is to use the Undo command
at the top of the Edit menu. Pull down the menu and look at this command now.
It reads Undo Typing, and if you use it, all the typing you have done since you
placed the insertion point will be removed. Undo always shows you what can be
undone. Almost all editing operations can be undone, the only exceptions being
the three operations performed with the buttons at the center of the screen. It may
read Cannot Undo, and be disabled (i.e., it is shown in gray, and does not respond
if you try to use it). This is because the file has just been loaded or saved, and you
have not yet made any changes: There is nothing to undo.

Set Origin changes the way in which the sequence is numbered, and has different
effects depending on whether the sequence is linear or circular. The origin of a linear
sequence is position number 1, which may be anywhere on the screen, or indeed
outside the sequence displayed. If your sequence represents a small segment of a
larger sequence that is itself numbered from 1, the first nucleotide displayed on the
screen will have a number >1. If, on the other hand, you wish to set the origin at
some feature in the body of the sequence (for example, at the start codon of a
translated region), the first nucleotide will have a negative number. By convention,
nucleotide numbering does not use zero, so you may not set the origin to zero.
Strictly speaking, when you set the origin of a linear sequence, you do not specify
the position of the origin itself, but rather the numbering of the first nucleotide.
Verify by Typing and Verify by Speaking are modal commands, i.e., you can
not do anything else at the same time, because the menus, scrollbars, and so on,
are all inactive. When the program has talked its way to the end of the sequence
it will exit automatically from this mode and return to normal operation. If you
wish to exit before the end of the sequence is reached (in order to make correc-
tions) you may do so by holding down the command key and simultaneously
typing a period. (This is the standard Macintosh abort command: You can stop
most operations in GeneJockeyll this way if you change your mind.)

The Find command in GeneJockey is similar to that in a word processor, but has
some special facilities for use with sequences. Since all sequences in GeneJockey
are in uppercase, it does not matter whether you type in the target sequence in
capitals or lowercase; the program will convert the characters to capitals before
searching. You can include degenerate codes in the target sequence, so AATNG
will find AATAG, AATCG, AATGG, or AATTG. Likewise, degenerate codes in
the search sequence will be honored, so AATTG will find not only AATTG but
NATAG, ANTAG, AANAG, and so on. The Find command will also permit you
to specify a number of allowable mismatches, so you can find sections that are
similar to, but not identical to the target sequence. You can also set the program
to find the minimum number of mismatches required to produce a match, by
means of the Find Mismatches button.



